Announcement

Collapse
No announcement yet.

Error 478 Resource File Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 478 Resource File Error

    Please add your comments and suggestions as a Reply to this thread.





    PB/WIN - Error 478 - Resource file error
    Resource file error - The resource file referenced has not been found or is not identifiable as a valid resource file. A common cause of this problem is attempting to use #RESOURCE with a non-PBR file, or if the PBR file was not able to be opened by the compiler (for example, because the file is locked by another process or application).

    Last edited by Gary Beene; 28 Oct 2014, 07:13 PM.

  • #2
    I just got this error

    What the heck? I just got the same error - #RESOURCE ICON -Error 478

    It didn't do that a week ago. No major change in my code.

    I'm searching to see if any one knows why.

    Checked the obvious - yes, it is there, not corrupted.


    Win XP, PBCC 6.03

    Comment


    • #3
      Hard to help without a code example of what you think should compile.
      Rod
      "To every unsung hero in the universe
      To those who roam the skies and those who roam the earth
      To all good men of reason may they never thirst " - from "Heaven Help the Devil" by G. Lightfoot

      Comment


      • #4
        Its often easy to see whats actually happening with file access-related issues simply by watching i/o with a tool like Sysinternals Filemon (or Process Monitor as it's since incorporated) - https://technet.microsoft.com/en-au/.../bb896642.aspx
        -

        Comment


        • #5
          Hi Daniel

          Originally posted by Daniel Raymer View Post
          No major change in my code.
          Which changes do you have into your code?

          I have got for years the same error.

          Then i switched to the latest resource compiler from Microsoft.

          Then I had no longer this error.

          Maybe that helps.
          Last edited by Joerg Buckel; 6 Apr 2015, 02:22 AM.
          • J. Buckel
            Amicus certus in re incerta cernitur.
            Marcus Tullius Cicero

          Comment


          • #6
            Error message is out of date. To Wit:

            A common cause of this problem is attempting to use #RESOURCE with a non-PBR file, or if the PBR file was not able to be opened by the compiler
            #RESOURCE also supports *.RES files - which might be invalid - as well as all the intrinsic '#RESOURCE resource type' statements.

            I "suspect" this same message is used only for either bad *.PBR or *.RES files, but that is just an (educated?) guess, as I do not use the any form of #RESOURCE except for *.PBR files created with an external script (*.rc) plus PBRES program.

            I "assume" there are discrete error messages for invalid "#RESOURCE resource_type" statements.
            Michael Mattias
            Tal Systems Inc.
            Racine WI USA
            mmattias@talsystems.com
            http://www.talsystems.com

            Comment


            • #7
              Old thread but I ran into this problem again, with an Icon file as before. This time, un-checking Read-Only didn't fix it, but using Run-As-Administrator when starting PB/CC did fix it.

              Cheers!

              Comment


              • #8
                I take it back - Run-As-Administrator worked just once. Now, without restarting PBCC, I get the same #Resource Error 478 from my Icon file. Worked yesterday. If I figure it out, I'll post the fix.

                Comment


                • #9
                  And it's BACK!

                  In June I got it to work by un-checking Read-Only and deleting the existing compiled EXE.

                  Now that doesn't work, and I get Error 478.

                  But, if I rem out this line, it compiles and runs just fine.

                  #RESOURCE ICON, 1001, "Dan38.ico"

                  That icon file is attached - nothing wrong with it, been using it for 15 years.

                  Above that is just:
                  #REGISTER NONE
                  #COMPILE EXE
                  #OPTION VERSION5
                  #INCLUDE "GFXT_Pro.INC"
                  #INCLUDE "CT_Pro.INC"
                  #INCLUDE "Win32Api.inc"
                  plus setting of a bunch of Equates like %DimCurveFit=100 and $CopyrightDate="2017" .

                  None of this was changed.

                  Running Win10, PBCC 6.03
                  Attached Files

                  Comment

                  Working...
                  X