Announcement

Collapse
No announcement yet.

Help File Mystery Symbol

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help File Mystery Symbol

    The help files for CC compiler vers 4 and 5 are peppered with
    a puzzling symbol. This may be an installation error on my part,
    but if not I would welcome clarification. For example:

    BIN$ function
    Return a ' that is the binary (base 2) representation of its argument.

    REGEXPR
    Scan a ' for a matching "wildcard" or regular expression.

    The "apostrophe" appears inside a small indented box. In the
    BIN$ case I can guess the ' could stand for "result". In the
    REGEXPR case perhaps the ' refers to "string argument".

    I am reading about the new OBJECT methods in ver 5 and here
    guessing what the apostrophes stand for is risky.

    Where have I gone wrong with this one?

    Ian Davies

  • #2
    Some Wild Guess - are you using non English system.

    Mine reads Return a [string] that is the binary (base 2) representation of its argument.

    [string] < is a hyperlink and shows links to string types in the help manual

    See if the on line manual under help desk looks OK ?

    Think support might be a better bet.

    Hope that helps
    A dozen what.

    Comment


    • #3
      Puzzle half solved

      Thanks for your comments Michael. The online help shows the
      hyperlinks correctly so evidently something is wrong with the
      way my help file is set up. I am using English (US) keyboard and
      normally have no trouble with links in other applications.

      It would be great to get it working properly.

      Comment


      • #4
        The problem is that the help file is using a Java object to display a menu when you click on the links, and Java support is not installed or is disabled. You probably need to change Internet Explorer settings to display these links properly.
        kgpsoftware.com | Slam DBMS | PrpT Control | Other Downloads | Contact Me

        Comment


        • #5
          Thanks for the pointer

          Thank you Kev. That gives me a direction in which to start
          looking for a cure.

          On reflection though the problem may not lie with my browser,
          because the the online forum help works perfectly. It is just
          the help from within my compiler IDE that isn't working as it
          should.

          Regards
          Ian
          Last edited by Ian Davies; 6 Sep 2008, 05:14 PM.

          Comment


          • #6
            I do not see java being used on the local help file. ? hhctrl.ocx ?
            A dozen what.

            Comment


            • #7
              You are quite correct Michael. hhctrl.ocx is present in windows\system32
              but is (apparently) not being invoked? Unfortunately I'm a beginner in
              such things. I'm getting closer to a solution (I think), but not sure
              what is the next step. Tried starting afresh by removing then
              reinstalling, but without success.

              Comment


              • #8
                Sorry, not Java, I meant a CSS class is being used -- it is not basic HTML

                If you want to see it for yourself, right click on a topic (ie. "REGEXPR") and select "View Source". Your version of IE either does not support this feature, or it is disabled. It is IE that does the rendering for all HTML help pages, not hhctrl.

                What OS/IE version are you using?
                kgpsoftware.com | Slam DBMS | PrpT Control | Other Downloads | Contact Me

                Comment


                • #9
                  Kev, I am running XP Pro with Service Pack 2. IE ver 6.0.2900.2180. IE
                  shows Java Plug-in 1.6.0_07 enabled. As I don't use Internet Explorer as
                  my web browser (Firefox 3), all the settings are at their default state.

                  If for some reason the feature (of displaying help files) is disabled,
                  where should I look to check? Many thanks for your trouble and help.

                  Comment


                  • #10
                    Michael, I had an email notification of your reply with a few lines of
                    content but for some reason, the post itself is not visible to me. You
                    may have already answered the question and if so, my apologies.

                    I guess this has resolved into two puzzles for me. (1) is that the
                    OnLine Help works perfectly, but the help from within CC5 IDE does not.
                    (2) and more importantly, I'd really like to know what I have to do to
                    get the IDE help working the same way as the OnLine help.

                    Comment


                    • #11
                      I was starting to reply - bounced between a few things - seen you have Firefox - while I was redoing what I was going to say - I sent instead of clearing the post, then deleted the post, Sorry

                      Just like now talking to my sister on the phone answering emails and posting here.


                      Firefox will not display those links correctly on them pages. Saved the source as html and viewed with FF

                      The error console complains about 4 things. The links are not shown as you mention in the first post.

                      IF Firefox is rendering your help files...you have to switch back to IE

                      I was under the impression that IE still rendered help files even if not default browser. Unless IE is locked down with no add ons and you need to get IE one step above that. I use IE locked down as far as you can go with out totally disabling add -ons and the PB Help works.

                      I had other issues with FF and made IE default and use FF when surfing. There is FF users here (they do not use IE at all ) maybe the will have the answer.
                      A dozen what.

                      Comment


                      • #12
                        Okay Michael, thanks for the help. I'll try some variations, perhaps
                        making IE the default (ugh!). Micro$oft do try hard to push sub-standard
                        applications by crowding out the opposition.

                        I haven't totally disabled IE, but put it this way: would you drive your
                        car on any roads where the traffic light software was written by MS?

                        Comment


                        • #13
                          I have Firefox as the default browser, but PB help render correctly: I think the default browser don't matters at all as far as the .CHM rendering is concerned.

                          Bye!
                          -- The universe tends toward maximum irony. Don't push it.

                          File Extension Seeker - Metasearch engine for file extensions / file types
                          Online TrID file identifier | TrIDLib - Identify thousands of file formats

                          Comment


                          • #14
                            Thanks guys for all your suggestions. Unfortunately the puzzle
                            remains no nearer a solution. Lance, do you know what is
                            happening here and how I can fix it? Many thanks.

                            Comment


                            • #15
                              Originally posted by Ian Davies View Post
                              : would you drive your
                              car on any roads where the traffic light software was written by MS?
                              How do know it isn't?
                              Regards,
                              Bob

                              Comment


                              • #16
                                Robert. I am reasonably confident that traffic light software is not
                                written by MS. How often do traffic lights:

                                1. Shut down with the message, "Lights have to close now. Sorry for any inconvenience"
                                2. Crash early and often during the day
                                3. Fail to turn green unless the driver has "activated" his car
                                4. Show green to opposing lanes, but this will be corrected in SP4

                                However, I would be disposed to believe anything you say should you come
                                up with a solution to the original problem!

                                Comment


                                • #17
                                  I am reasonably confident that traffic light software is not written by MS.
                                  Well, maybe today...

                                  Bill Gates' and Paul Allen's first software company was Traf-O-Data, which did.... traffic light software.
                                  Michael Mattias
                                  Tal Systems (retired)
                                  Port Washington WI USA
                                  [email protected]
                                  http://www.talsystems.com

                                  Comment


                                  • #18
                                    What is supposed to be at these locations is a HtmlHelp See Also AKLink, which is an ActiveX Control. You need to change your IE security settings to allow signed ActiveX controls.

                                    If changing your IE security settings has not fixed this problem, then can you tell me if the help file is installed on a network drive? If so, can you tell me if the control then displays correctly if you copy and run the CHM file locally?

                                    If you have installed to a local drive, install the latest HTML Help security patch (http://support.microsoft.com/kb/896358), if you haven't already done so. This is typically delivered via Windows Update and, on XP, it upgrades the version of hhctrl.ocx to 5.2.3790.2453.

                                    If this does not help, try the steps at http://support.microsoft.com/default.aspx/?kbid=822989, where one of the problems listed
                                    on this page talks about the problem of "Some links appear as a small box with a dot in the center.".

                                    If these do not resolve the problem, try re-registering the HTML Help ActiveX control from the command line. To do this, open a Command Prompt window and type these two commands:

                                    regsvr32 /u %windir%\system32\hhctrl.ocx
                                    regsvr32 %windir%\system32\hhctrl.ocx

                                    The first command unregisters the control; the second registers it again.

                                    Also, make sure that you do have all the Windows XP updates installed and you may consider upgrading to IE7, as IE installs the core HtmlHelp components. I really hate to say this, I know how Windows updates can be, but if the above steps to not resolve this, it maybe your only choice?

                                    And lastly I can suggest that you run MJ's Help Diagnostics from http://www.helpware.net/downloads/, which will check the status of all the HTML Help viewer components on your system. The only section of the MJ's Help Report that is relevant to your problem is the one headed "HTML Help Run-time Components". If need help you can send this report to support and it will be reviewed.
                                    Sincerely,

                                    Steve Rossell
                                    PowerBASIC Staff

                                    Comment


                                    • #19
                                      Thank you very much Steve. It will take me some time to explore
                                      all these possibilities and I will reply when I have done so.

                                      Comment


                                      • #20
                                        Success

                                        Steve, I ran the MJsDiag.exe test. The report indicated that the HTML
                                        Help Run-time Components were all registered OK.

                                        The hhctrl.ocx is Version = 5.2.3790.1194, a bit earlier than the
                                        5.2.3790.2453 one you recommended.

                                        To shortcut further tests I installed MS SP3. That did the trick. The
                                        help file now works as expected.

                                        Comment: I have been wary about installing ad hoc patches and upgrades
                                        in the past because I have found some MS patches may cure a current
                                        problem only to introduce errors with something else that was previously
                                        working. However on this occasion there were too many unknowns so I bit
                                        the bullet and the help file works. Only time will tell whether the
                                        upgrade has crippled something else.

                                        My grateful thanks for your time and effort in addressing my problem and
                                        for pointing me in the right direction to solve it.

                                        Comment

                                        Working...
                                        X