Announcement

Collapse
No announcement yet.

PBCC 5.0 with Xp Pro

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PBCC 5.0 with Xp Pro

    I have recently released a new version of my baseball sim product (www.nostalgiabaseball.net) compiled with 5.0. Several users have reported back display issues (program won't always fire up or shut down properly, or seems to freeze). I'm using Console Tools with Graphics in this application, and that's important information as it turns out.

    I went into work where I, too, have Xp Pro and sure enough, the program won't start via the Console Tools .CWC file that I've been using for years.

    I recompiled using 4.04 and everything works fine.

    I'm guessing that maybe the forward referencing for DECLARE could be the problem, since it obviously does something different with internal memory. But who knows ... I'm only guessing. I just thought I'd report the issue and see if anyone else had encountered similar issues.
    Craig J. Slane
    Nostalga Sim Baseball

  • #2
    Craig,

    I don't use your program, but I have used Console Tools and PBCC 5.0. I have had to cease use of it since upgrading to PBCC 5.0 and Windows Vista, because with even a single call to the CT library, certain elements of Vista then eventually become unstable on my system, eventually requiring me to reboot. For example, after a few minutes of using a program that uses console tools on my copy of Vista, the Windows Explorer interface becomes garbled and shows all kinds of visual artifacts. If I recompile without the CT calls, the program works fine and Vista behaves itself. I admit I haven't tried to troubleshoot whether it's the combination of PBCC 5.0 and Console Tools that troubles Vista, or whether it's just Vista and Console Tools regardless of the PBCC version. I also haven't reported my problems with CT to the vendor, or sought help at all for that matter, since I can easily work around my need for CT altogether, and that just seemed easier to me.

    I would be interested to know if others who use Vista are having any issues with their use of CT and PBCC 5.0 causing Windows Explorer problems. I know that Windows is supposed to protect processes from interfering with each other, but it doesn't appear to be doing so for me in this particular case.

    Comment


    • #3
      I use PB/CC 5.0.0 with win xp/pro and other than some legit bugs I found I have had no other problems.

      I do not use any third-party software (eg Console Tools) with these programs, and I have never even played with the GRAPHICS stuff.
      Michael Mattias
      Tal Systems Inc. (retired)
      Racine WI USA
      [email protected]
      http://www.talsystems.com

      Comment


      • #4
        I've never had any issues with CT to this point. It has caused no problems whatsoever on my Vista machine for the last year. I have 100s of users and never a barrage of complaints like this, so I know something is up. For now, I've quite using 5.0 and gone back to 4.04 until I can figure out what's going on.
        Craig J. Slane
        Nostalga Sim Baseball

        Comment


        • #5
          Craig and Patrick --

          Sorry I didn't pick up on this thread earlier, PowerBASIC support just sent me an email about it. In the future, for a much quicker response, please report problems with Console Tools and other Perfect Sync products in the PB Third Party Forum, and/or by direct email to the address below.

          This is the first we have heard about any of these problems from anybody, and we are very interested in tracking them down. Even if you have developed workarounds, I'd be grateful if you'd help Perfect Sync find the root of the problem.

          I don't have a lot of information to go on, but the common elements seem to be Console Tools and PB/CC version 5. If you elimiate one or the other, the problems go away. Does that match your experience? Or are we seeing a difference when XP vs. Vista is used? (It doesn't sound like it.)

          Craig is using the CWC wrapper program. Patrick, are you?

          > the Windows Explorer interface becomes garbled and shows all kinds of visual artifacts.

          Wow, that sounds very serious. Can you be more specific? Email me a screen shot?

          -- Eric Pearson, Perfect Sync, Inc.
          "Not my circus, not my monkeys."

          Comment

          Working...
          X