Announcement

Collapse
No announcement yet.

The infamous error 496 again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • The infamous error 496 again

    Hello, guys;

    I have run into the infamous destination file error again. I know there have been several posts on this issue in the past. What is strange now is that the so-called destination "process" does not show up in Windows Task Manager. After several other frustrating attempts, I was finally able to locate the file by searching, and then from Windows Explorer. To my bewilderment, it shows a 0-bytes file size and the custom icon is replaced with the bland generic icon. I am able to delete it manually and try again. This happens with every PBCC program I have tested since the early hours of this morning.

    My programs (each created on PBCC5 or PBCC4), runs without a problem the first time. Thereafter, the destination file error gets in the way again and the agony resumes.

    The problem started when Spyware Doctor reported a 'suspicious activity trying to modify the process.' I let Spyware Doctor quarantine the process, and this lead to the disappearance of my PBCCEdit. I decided to perform a system restore, which successfully restored my PBCC5. I also ran a full scan with Spyware Doctor, which reported that everything was ok.

    The destination file error complaint persisted and I decided to install The Install Shield Deluxe 2009. A six-hour full scan reported one unresolved issue. At this point, I have no where else to turn to.

    Can anyone out there rescue me, please? Might reinstalling PBCC resolve the problem?, Or, what else? Thanks.
    Last edited by George Oluikpe; 28 Feb 2009, 11:12 AM.

  • #2
    Originally posted by George Oluikpe View Post
    Hello, guys;

    I have run into the infamous destination file error again. I know there have been several posts on this issue in the past. What is strange now is that the so-called destination "process" does not show up in Windows Task Manager.
    Not sure if this will help, but I have had some code I've written where the app doesn't exit properly. PB can't create the new file because the process is still running. This is what I was able to do.

    Start Task Manager (Ctrl-Shift-Escape)

    Find the name of the process (Will be the name of your app exe)
    Right click - End Process Tree. End Process will not work.

    At this point I could recompile.

    Hope this helps.

    Comment


    • #3
      >Thereafter, the destination file error gets in the way again and the agony resumes.

      You can't assume "file in use" is the ONLY cause of error 496.
      Destination file write error - During compilation the compiler received a disk write error. This can occur if the destination EXE is, for example, still running in memory when you attempt to compile, the target file is write locked by another process or compile session, or the target file is write-protected (read-only).
      It can also occur if the path or filename in the #COMPILE statement is invalid, and probably for some other file/path reasons, too.
      Michael Mattias
      Tal Systems (retired)
      Port Washington WI USA
      [email protected]
      http://www.talsystems.com

      Comment


      • #4
        Path Problem

        Execute CMD
        Next type PATH
        You may be surprised at the length of your path
        Your problem is inside one of those folders
        Type PATH=\MyProgramFolder that will be where your PBCC is
        If you can compile normally it will prove that theory
        Old QB45 Programmer

        Comment


        • #5
          The infamous destination file error

          Thanks, guys.

          As I pointed out in the original post, the first time I run any of my programs, it compiles and runs successfully. The error occurs on the second and subsequent attempts. What I did not point out (which I believe, everybody who has run into this problem knows) is that if I rename the exec before compiling it will run successfully once and then the error surfaces on subsequent attempts, unless I rename the exec each time.

          Secondly, the compiled exec does NOT show at all in Windows Task Manager, no matter how I invoke the (TM). I can only locate it by standard file search or via Windows Explorer, where it shows with 0-byte file size. I suspect (I'm not sure) that this is why Task Manager does not pick it up. From Windows Explorer, I can manually delete the 0-byte exec. But, again, after the first run following each deletion, the vicious cycle starts again.

          With these clarifications, I am hoping that somebody will come up with a viable solution. For now, thanks, all.
          Last edited by George Oluikpe; 28 Feb 2009, 08:56 PM.

          Comment


          • #6
            My bet is that your process is still running.

            If I was a betting man....

            It sure looks to me like your process is still running.

            Load up PROCEXP from http://technet.microsoft.com/en-us/s.../bb545027.aspx , set the time for color changes to 9 seconds... compile and run your app, select it in procexp then close / end your app... see if it really goes away in procexp...
            Warped by the rain, Driven by the snow...

            jimatluv2rescue.com

            Comment


            • #7
              Does the problem persist if you temorarily disable your Anti-virus, and SpyWare Doctor?
              Real programmers use a magnetized needle and a steady hand

              Comment


              • #8
                >but I have had some code I've written where the app doesn't exit properly

                Hmmm... Good thought.

                So how does this naughty program exit? (Code not shown)
                Michael Mattias
                Tal Systems (retired)
                Port Washington WI USA
                [email protected]
                http://www.talsystems.com

                Comment


                • #9
                  It seems that all of his programs have the same problem so if any of the old ones that used to work ok have stopped working, the problem is elsewhere.
                  Have you tried to change your source folder ?
                  How about checking your PBCC IDE Window options ?
                  Old QB45 Programmer

                  Comment


                  • #10
                    You didn't tell us which version of OS is running nor which anti-virus/
                    anti-spyware are running. If you don't want to stop those last two then
                    check them to see if they might be holding the executable open ( maybe
                    pending on a check with their web-site ). I know I had a lot of trouble
                    with SpyWare Doctor a couple years back and had to totally remove it
                    to clear up some problems.

                    Worth a look see.

                    Comment


                    • #11
                      It's almost a certainty that this is caused by an over-aggressive anti-virus program. Remove them and try again. Most likely, all will be well again.

                      Bob Zale
                      PowerBASIC Inc.

                      Comment


                      • #12
                        Thanks again, Guys.

                        I had taken some time away from the computer in frustration -- perhaps, burying my head in sand. Before doing so, I had uninstalled my PBCC5.00 (this was based on the advise of a local technician who feared that my PBCC editor might have become corrupted), with the intention to reinstall it later.

                        To respond to some of the questions raised in recent responses, the OS is Windows XP Professional (with service pack 2). The anti-virus software that raised the initial alert about a suspicious activity was Spyware Doctor, which I have used for about a year without a problem. I turned it off (did not actually uninstall it) before installing Shield Deluxe 2009.

                        A second full-system scan (using Shield Deluxe) reported one unresolved problem, with the following partial details:

                        Threat name:
                        Application.Powerreg.Scheduler.B

                        Object name:
                        C:\System Volume Information\-restore{15A42EEF-7989-4474-8DBG-59519360F54C}\RP956\A0133394.exe

                        I don't know whether this rings any bell, I can't interpret it. I thought of exploring all other options before attempting to reinstall PBCC5, and then trying out the suggestions you guys offered.

                        Always appreciative of suggestions,
                        G. C. Oluikpe
                        Last edited by George Oluikpe; 2 Mar 2009, 09:19 PM.

                        Comment


                        • #13
                          The infamous error 496

                          Hi, Gentlemen;

                          I believe that I have caught the culprit. In particular, Paul, Bud and Bob hit the nail right on the head. Spyware Doctor had metamorphosed into a full-blown virus!

                          Weighing all the suggestions and the fact that, during the last hours of my nightmare, it was taking more than half an hour just to launch Microsoft Word, and I could not even save a line of text, I fanally decided to purge out Spyware Doctor. It took nearly an hour to do just that. In the end, I reinstalled my PBCC5. So far, everything seems to have returned to normal. While I do not want to celebrate prematurely, I will take a glass of red wine and sleep like a baby.

                          At this point, I have joined the line of victims of Spyware Doctor and must stay away from it like AIDS.

                          Once again, thanks, guys. You have all been great.

                          Sincerely,

                          George C. Oluikpe.

                          Comment

                          Working...
                          X