No announcement yet.

Cannot access compiler results

  • Filter
  • Time
  • Show
Clear All
new posts

    Was reinstalling Windows from scratch a clean install or just a refresh keeping files.


      From scratch. Uninstalled using Control Panel and then deleted what was left in the original installation folder.


        Might get lucky with ATTRIB -R -S in case something is marked read only.
        Might do a partition and clean install to get new everything.
        Might copy to a USB drive and see if it runs off that. If it does, I'd guess the registry is corrupt.
        Definitely run SFC /SCANNOW and CHKDSK /F
        Could boot up in safe mode or turn off most things using MSCONFIG and see if it runs.


          Originally posted by Gary Beene View Post
          Well, I've decided to join the club - started getting the Cannot access compiler results as of a few minutes ago.

          I just got through changing the better part of a thousand lines of code - simple changes, but included a lot of adding a Macro

          "I found the problem. It has to do with the order of compiler directives at the top of the main program. Moving macros to the top allows the compiler to flag errors that resulted in the error message above (a kind of forward reference problem).

          I also see this was an established thread for the PBWIN compiler too.​"




            Howdy, Stuart!

            Yep, I tried that. No success. I move them as high as they could go.

            The PC on which it worked earlier was a Win10 machine.

            Tried running it from my main Win11 PC PC again, this time from the flash drive and it fails.

            I tried it on a 3rd PC, (Win11) and it fails with the same error message.

            So for it only works on the Win10 PC.


              Mixing macros from PB and Jose Roca?


                Howdy, Mike!

                No, the Macros were of my own code. As a test, I commented out the Macro innards and it still fails

                The Macro code did not change during this marathon edit session.

                Compiling regularly after each few changes might have helped in this situation. Too late now!

                Why it compiles in Win10 and not Win11 is a tease of information.

                And why now with edits that seem benign - at least, that don't give any normal compiler error?


                  My shortcut to PbEdit on Windows 11 is run as administrator.


                    Howdy, Mike!

                    Mine too!


                      Problem resolved. I can now compile.

                      My macro is named "MY".

                      I accidentally typed it in like this, at the end of one CASE (where I wanted it) but also at the start of the next CASE line, where it did not belong.

                                  CASE %IDM_InstallationFolder : MX : ShellExecute(hDlgCenter, "Open", (EXE.PATH$), $NUL, $NUL, %SW_RESTORE) : MY
                       : MY            CASE %IDM_Force1920          : MX : Force1920 XOR=1    : Announce Force1920, "Force1920"
                      Instead of giving me a compile error that pointed to these lines, the compiler gave the the error message we've been discussing.

                      I found the problem by redefining the MACRO as a Sub by the same name, and that allowed the compiler to point to the line with the error. Out of a thousand edits, I'm lucky there was only the one (so far) error - but unlucky that the error caused the compiler to give a not-very-useful error message!

                      Thanks for your replies! Sorry that it was a coding error that I wasn't able to find before asking for your help!


                        Gary (our equivalent of the Shell answer man) make a mistake? Surely, the cat must have walked across the keyboard. And no, I am not calling you Shirley.

                        Seriously, I am glad you caught that one. Very hard to trace an issue when the compiler's info isn't particularly helpful.


                          Gee, and all this time I've not used colon new logical lines very much because I didn't like reading it later. With MACROs the compiler does like it either Very glad you caught it

                          Still, with CASE indented from SELECT CASE and code within the CASE further indented, how did ":MY" being to left of vertical line from SELECT CASE to SELECT END not "hit you in head with 2 by 4"? Up coding too late? Coffee shortage?

                          Back to serious. Very happy it was just code bug, not some insidious conflict between the depths of PB and the OS.



                            Howdy, Dale!

                            I was doing a lot of pasting and it looks like I accidentally hit ENTER + paste ... something like that. Usually if my fingers don't do what my brain tells them, I see what I've done wrong. But in this particular case (pun intended) I was on the end of a long string of 2am nightly coding runs and apparently not at my mental best.

                            Last night I went to bed at 8:30pm and didn't get up until about 8am the next morning. That never happens!

                            I guess I got what I deserved for not taking time off to get needed rest!

                            And yes, I was darned happy that it turned out to be an easy-to-fix thing.


                              > Why it compiles in Win10 and not Win11 is a tease of information.
                              It worked in Windows 10?


                                Gary Beene It happens to all of us. Recently I did something very similar working on a site and one misplaced tag when I pasted some code, it wasn't displaying right. Spent almost an hour trying to figure it out. But, it was after two hours of sleep for the previous two nights.


                                  Howdy, Mike!

                                  Yes, it worked on Win10.

                                  No error message of any kind.

                                  How can that be?


                                    It confused me too, as well.