Announcement

Collapse
No announcement yet.

No EMS under Win98

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No EMS under Win98

    I have a PbDos3.5 program that I’m trying to run on a Win98 machine. The program uses DIM VIRTUAL and so requires EMS support. The program checks for the availability of EMS with the following code and when I run it on the Win98 box it issues the error message.

    Code:
    IF NOT FRE(-11) > 500 * %Kbyte THEN        'Currently we need 384 Kbyte EMS
      CALL SoundAlert
      PRINT "ERROR. EMS memory not available."
      END
    END IF
    When I look at the properties (PIF) for the executable, on the “Memory” tab under “Expanded (EMS) Memory” I see “The computer is not configured for expanded memory in MS-DOS sessions”. When I click the “Details…” button I see “The third party memory management software has not been configured for expanded memory. Consult the product documentation for instructions on how to enable expanded memory”. All other memory types, Conventional, XMS and MS-DOS protected, on the Memory tab are set to Auto.

    In my config.sys I have the following.

    dos=high,umb
    device=c:windows\himem.sys
    device=c:\windows\emm386.exe 1024 RAM

    It’s been some time since I’ve played with DOS/PbDos so I’m very rusty on these things. I can’t remember running across this problem before and have had no trouble running the program on XP and other Win98 machines.

    Keith


    ------------------

  • #2
    Have had this happen and corrected by creating a new shortcut.
    Went through every option in the pif without seeing any
    differences. The new shortcut has fixed it everytime.



    ------------------
    How long is an idea? Write it down.

    Comment


    • #3
      No Mike – just tried that and it doesn’t work – still the EMS is disabled.

      ------------------

      Comment


      • #4
        I have EMS back. But I don’t quite understand how. I edited the config.sys to

        device=c:\windows\emm386.exe NOEMS

        and rebooted. The pif properties, correctly, said EMS is disabled with this. Then I edited the config.sys back to

        device=c:\windows\emm386.exe 1024 RAM

        and now everything works ok. Perhaps it was a bit like you said Mike – give it a kick and it works.

        Keith



        ------------------

        Comment


        • #5
          Hello Keith!

          You can emulate EMS functionnalities in Win98 if you add one of this lines in the system.ini:

          [386Enh]

          EMMPageFrame=C800
          ; provide EMS/XMS, but i can't use it because of a big problem with my Ms-Dos programs which use the Maxlib libraries:
          ;$link "MAXLIB.PBL"
          ;$include "MAXLIB.BI"
          ;InitXMSArray


          EMMInclude=D400-E3FF
          ;no problem for me and the Maxlib lib.! All my programs run fine !
          ;following adresses work also on my PC
          ;EMMInclude=D800-E7FF
          ;EMMInclude=DC00-EBFF
          ;EMMInclude=E000-EFFF
          ;EMMInclude=D000-DFFF

          I have also no need of Himem.sys and EMM386.exe in my config.sys


          ------------------
          Sorry for my poor english ! I am a Frenchman
          Sorry for my poor english ! I am a Frenchman

          Comment

          Working...
          X