Announcement

Collapse
No announcement yet.

Closing App & PB35 and still not able to delete or rename compiled .exe

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Closing App & PB35 and still not able to delete or rename compiled .exe

    I load the .bas file, edit it, create the .exe application. Close PB35. Run the application. The application ends. Now I try to RENAME or DELETE the created application .exe and I am told I cannot do it, its still in use!!!!!

    Yes I am running the application in xp2. No don't tell me its windows fault because I create and run .com and .exe files with other compilers such as Turbo pascal and its not an issue with the .exe's they create.

    I have even opened Task Manage to verify that the compiled .exe application and PB35 IS NOT RUNNING. I have looked at the properties of the created application and it is not marked as read only.

    So why does this happen?

    I'm soooo confused.....
    LEARNING EXPERIENCE: What you get when you didn't get what you THOUGHT you wanted!

  • #2
    More Reasearch - Still Problem!!

    I thought it might be because of the compiled size 94k. However thats not true either it does it even with a very simple program such as below.

    [code]

    For L = 1 to 10
    Lprint "The number is: ";L
    For W = 1 to 20000
    Next W
    Next L

    [\code]

    I used dependency checker and it shows nothing for the compiled .exe. I used dos attrib and it shows no attributes set for the .exe. Its almost acting like stupid M$ Vista Os acts when you try to tell it your the Administrator ( Just try to rename a system file sith Vista - Boy are u in for a challenge!)

    Still a problem, looks like it could be a PB35 bug maybe, strange no one has found it yet. The only way around it is to reboot the machine then you can delete the .exe. I can't even recompile the .exe and save it after I make changes to the source files! Oh yes, I can change or delete the source files with no problems at all though.

    Still Confused....
    LEARNING EXPERIENCE: What you get when you didn't get what you THOUGHT you wanted!

    Comment


    • #3
      I'm running XP sp3. In PBDos 3.5 your code runs fine both from the IDE and as an EXE. I'm not getting any messages about the file being in use when I try to rename, copy, delete, or move the EXE.

      Sounds like the problem may not be PBDos. Is there a background app or service running that controls or limits your file access... maybe an AV app, or a critical folder manager?

      That's only a guess.

      Stan
      Do not go quiet into that good night,
      ... Rage, rage against the dark.

      Comment


      • #4
        Still in progress

        Well whatever it is apparently it is machine related, you put me on the right track. I copied the file to a flash drive and put it on one of my laptops, ran it, then deleted it with no problem at all.

        Hmmm....... It was'nt the AV I stopped it and had no affect but something sure is doing it.

        Thanks!

        LEARNING EXPERIENCE: What you get when you didn't get what you THOUGHT you wanted!

        Comment

        Working...
        X