Announcement

Collapse

New Sub-Forum

In an effort to help make sure there are appropriate categories for topics of discussion that are happening, there is now a sub-forum for databases and database programming under Special Interest groups. Please direct questions, etc., about this topic to that sub-forum moving forward. Thank you.
See more
See less

Shell Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Shell Problem

    I wrote a dos PB program that shell's to Lance's dosprint.exe
    program <which is a neat program by the way >. I wrote the
    program at home and everything worked great. However, I took
    it to work and loaded on my networked computer and it wouldn't
    execute the shell. The error message that flashed on the screen
    was "incorrect Dos version."

    I rebooted the computer and didn't load the network and program
    ran fine. Go figure?

    Has anyone had a similar problem and is there a solution.

    ------------------
    Rodney at Wirtz dot com

  • #2
    I haven't had that problem, but I have also have a shell problem.

    I'm shelling out to some windows apps. When I do, my dos app is
    placed on the systray. Before shelling I use int 2F, function
    168B and I send it again after shelling, but to no avail. My dos
    app remains on the systray until I click on it.

    Any suggestions would be appreciated.

    ------------------
    Walt Decker

    Comment


    • #3
      Rodney:
      You probably have two different operating systems on the
      network. For example, you may be running Windows/98 on your
      file server and Win/95 on the terminal. When shelling, your
      Win/95 terminal or DOS app may be trying to access the
      COMMAND.COM file on the server and something is coming into
      conflict with the two different operating systems. Check to see
      where the SHELL statement in your terminal CONFIG.SYS file
      is set to look for the COMMAND.COM (or whatever). If it's set to
      look on the file server, try changing it to look for it on your
      terminal.



      ------------------
      There are no atheists in a fox hole or the morning of a math test.
      If my flag offends you, I'll help you pack.

      Comment


      • #4
        Rodney, are you executing DOSPRINT.EXE directly, or are you executing it through a an intermediate file (ie, a .BAT file, or...)? Also, be sure that you are including the ".EXE" extension, ie, "DOSPRINT.EXE" rather than "DOSPRINT".

        For example:

        SHELL "DOSPRINT.EXE filename.txt,HP Laserjet,,/80"

        Mel, the minimized-taskbar problem can occur if you shell from a (possibly full-screen) DOS box to a *GUI* Windows application... I have a small freeware utility called WINLINK that can help solve this problem... you simply launch WINLINK.EXE and pass your previous command-line as a parameter. WINLINK launches the target app and restores the original DOS window to it's previous state when the target app terminates.

        For example:

        SHELL "WINLINK.EXE DOSPRINT.EXE filename.txt,HP Laserjet,,/80"

        It you would like a copy of WINLINK.EXE, send me an email to my personal address mailto:[email protected][email protected]</A> and I'll send it to you. All registered DOSPRINT customers will receive WINLINK.EXE with the new V1.20 release (which is due for release this week).

        We are working on a new website for DOSPRINT (and the Windows DLLPRINT library) this week too... it's under construction right now... keep an eye on www.dosprint.com and www.dllprint.com !

        Regards,
        Lance
        Lance
        mailto:[email protected]

        Comment


        • #5
          Lance:
          Thanks for the comment. I am calling dosprint.exe correctly.
          I've even tried shelling to command.com. No help.
          I think it must have something to do with what command.com the
          computer is trying to use...

          Mel:
          Thanks for your comment too. I'll check that out at work
          tomorrow. I'll let you know if I find anything. As a note,
          I also tried running the same shell statement on two other
          computers and got the same result.

          Rodney...


          ------------------
          Rodney at Wirtz dot com

          Comment


          • #6
            What does the COMSPEC environment variable return on that PC?

            You are running Windows95 or better on these PC's, right? (DOSPRINT requires Windows95 or better to be running, since it is a Win32 application, not a DOS application).



            ------------------
            Lance
            PowerBASIC Support
            mailto:[email protected]suppo[email protected]</A>
            Lance
            mailto:[email protected]

            Comment

            Working...
            X