No announcement yet.

Help! - Windows 2000 Professional

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help! - Windows 2000 Professional

    I've just bought a new laptop running Windows 2000 Professional.

    Running MSDOS full screen the size is 80x50 and there are only 4 pages of video memory available instead of the usual 8 which is preventing programmes from running.

    Running MSDOS as a window there is a vertical scroll bar and there appears to many more lines available, although the usual 8 pages of video memory are available.

    Is there any way I can get these back to 80x25 and (for full screen) 8 pages of video memory.

    I am also having a problem running a compiled programme which just will not start even though it runs OK from the IDE. Does anyone know of any issues?

    Thanks in advance.
    Roy Petrie


  • #2
    By default, Windows NT/2000 default to DOS windows with 80x300 rather than the more "usual" 80x25 mode. I believe XP does the same thing.

    Changing these defaults is pretty straightforward though:

    Firstly, set the IDE size in the PB editor OPTIONS section to 25 line mode.

    Next, set the preferences for the DOS window itself -- when the IDE is running, press ALT+SPACE, then choose Properties.

    Adjust the Window Size and Screen Buffer Size to 80x25. Uncheck "Quick Edit", check "Full Screen", then click Ok.

    Finally, choose "Save properties for future windows with same title".

    That should get you back to 80x25 mode in the editor and the DOS window.

    After these changes, please let us know about the number of screen pages available to your app.


    PowerBASIC Support
    mailto:[email protected][email protected]</A>
    mailto:[email protected]


    • #3

      Thanks, you're a star! Everything working fine now and I have my 8 pages of video memory back.

      The programme that wouldn't run was called "start.exe" and "start" is now an internal DOS command.

      Thanks for your help.