Announcement

Collapse
No announcement yet.

NT Service Pack differences in Edit control?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Scott Turchin
    replied
    If memory serves me correct I believe there was a problem with the Ole control, not that I'm using that, but the OS is....I vaguely recall this being an issue, guess I was looking for confirmation, but since it works fine on Sp4 + I'm OK with that...

    Thanks,
    Scott

    -------------
    Scott Turchin


    Leave a comment:


  • Lance Edmonds
    replied
    In Win2K (build 2195), %ES_RIGHT produces the expected effect... maybe you have a SP-related problem? Also, check out msdn.microsoft.com and see if there are any notes...

    Good luck!

    -------------
    Lance
    PowerBASIC Support
    mailto:[email protected][email protected]</A>

    Leave a comment:


  • Scott Turchin
    started a topic NT Service Pack differences in Edit control?

    NT Service Pack differences in Edit control?

    If I do this:

    Control Add TextBox,hDlg, %IDTEXT1,"",5,10,100,10, %ES_RIGHT Or %WS_TABSTOP Or %ES_UPPERCASE,%WS_EX_CLIENTEDGE

    On NT Sp3, the cursor starts from the left, the text goes on the right, and it's very strange...
    If I do it on NT 4.0 SP6 I don't see this behavior, is this an MS bug?

    It doesn't happen on 98 either.....
    Now, this is subclassed, from my posts about that subclassing you can try iteither way I guess.., I'd be curious to see the results tho..


    Scott

    -------------
    Scott Turchin


Working...
X