Announcement

Collapse
No announcement yet.

small wishes for next PBDLL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • small wishes for next PBDLL

    Hello all...

    I don't know about you guys but I would really like to see some of the following additions to the next PBDLL...

    1. Allow dots in function/sub names. "function draw.apples()".
    2. String managment with format$ like the old "using$" addon.
    3. Allow more that one variable in format$.
    4. Add MAKWRD/MAKINT to compliment MAKLNG/MAKDWD/MAKPTR.
    5. Allow INCR/DECR to use a constant. "INCR variable,8"
    6. Maybe replace "()" with "[]" for arrays?

    All of these are really in the intrest to make the screen a bit more readable. Not that theres a problem now but hey! these are just some small things that I would like, Particularly #1 and #2.


    Cheers!

  • #2
    1. Allow dots in function/sub names. "function draw.apples()".

    There were intentionally disallowed, so there is little hope that they will be reinstated. Periods are only used with UDT and UNION structures.


    2. String managment with format$ like the old "using$" addon.

    This can be implemented in a user-defined function called USING$().


    4. Add MAKWRD/MAKINT to compliment MAKLNG/MAKDWD/MAKPTR.

    As we mainly deal with 32-bit values, how often do we need to build a Word or Integer from a pair of bytes? This is so easy to implement with a UNION if it is really needed.


    5. Allow INCR/DECR to use a constant. "INCR variable,8"

    I agree with this one!


    6. Maybe replace "()" with "[]" for arrays?

    Here I disagree... we need to be able to clearly distinguish between indexed pointers and array subscripts.


    Regardless of my personal opinions, your comments have been passed along to R&D.

    Thanks!


    ------------------
    Lance
    PowerBASIC Support
    mailto:[email protected][email protected]</A>
    Lance
    mailto:[email protected]

    Comment

    Working...
    X