Announcement

Collapse
No announcement yet.

Installation requirements.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lance Edmonds
    replied
    The compiler (and the IDE) do not require any version of WinSock - your code might, but the compiler does not. Your initial question asked about "installing PB6 on Windows 95a".

    From the "TCP and UDP" chapter in the help file:
    PowerBASIC requires version 2.0 or later of Winsock..

    The Winsock 2.0 is available from the PB ftp site.

    I guess we could change the helkp file to explicitly note that *applications* compiled with PB/DLL or PB/CC (that use the TCP/UDP functionality) will require Winsock 2.0.


    ------------------
    Lance
    PowerBASIC Support
    mailto:[email protected][email protected]</A>

    Leave a comment:


  • Guest's Avatar
    Guest replied
    What about that comment that PB6 requuires a certain version of Winsock?

    Something Dave said i think, for about 6 months or so.

    In sort, it would be nice IF there were things to mention, it could be placed in then Faq i guess.

    Thanks,


    ------------------

    Leave a comment:


  • Lance Edmonds
    replied
    Only if your code needs them! The compiler uses nothing that is not provided by a clean install of Win95 itself.

    I'm not at my DEV PC to confirm this, but I'm fairly sure the IDE (PBEDIT) installs one (possibly two) DLL's but they stored are in the PBDLL\BIN folder.



    ------------------
    Lance
    PowerBASIC Support
    mailto:[email protected][email protected]</A>

    Leave a comment:


  • Guest's Avatar
    Guest started a topic Installation requirements.

    Installation requirements.

    Does PB6 needs additional files to be installed on Win95a or other?

    I lost my Win95a version somehow to test if a an exe could run without additional installation.

    VB6 places stdole and more ole stuff, PB needs to do so too?

    Thanks,
Working...
X