No announcement yet.

WinAPI file error ... ?

  • Filter
  • Time
  • Show
Clear All
new posts

    WinAPI file error ... ?

    I un-installed Delphi 4 (about 240 meg liberated), but in the
    process it lost my Windows API Help file(s) for me.

    Then I downloaded the WinAPI file (the 8.3Mb jobbie) from the
    PowerBasic 'files', installed it, and it gave me an 'illegal
    operation' message whilst preparing the word list.

    Actually downloaded the zip file again, but with the same result.

    I am on Windows 98. Has anyone else had this problem?

    Btw, I have received my Pezold 5th edition Programming Windows
    at last, for the information of those who so often recommended
    and urged that every kitchen should have one.



    I had the same problem once upon a time. I use NT4 and what cured
    it for me was updating my explorer version. If I'm not mistaken,
    ver 5 or better will cure it. I know 5.5 will.

    M$ has this nasty habit of throwing it all sorts of DLL updates
    when they release a new version of explorer.

    You can also access the help stuff on MSDN. In fact this is the
    most up-to-date info. I don't think they update the std help
    file anymore, so what you have now is somewhat out of DATE!!!!

    Now that you have Petzold finally, I would HIGHLY recommend
    "Win32 Programming" by Rector/Newcomer.




      Also, search your system for any existing win32.gid and win32.fts files (these may be hidden). Delete them. They will be created automatically when you first use win32.hlp.

      (These files can cause a conflict if you had a previous, different version of win32.hlp, which is why you need them to be recreated).

      Tom Hanlin
      PowerBASIC Staff


        Cecil and Tom, thanks for you response.

        Cecil, I tried to search MSDN's site for "Win32.Hlp" and also
        for the zip file by name. Theirs is a strange search device; it
        goes off to perform the search (ostensibly) and then invites you
        to specify the search again, with no mention of "no files found"
        or anything similar. Gave up, eventually (more than an hour
        later), even though the thought of an up to date file is very

        Tom, I actually located a Win32.gid (hidden) and reset the hidden
        attribute after restarting in DOS mode, then renamed the file to
        something else with the .gid suffix also change to .prv, and
        restarted the word list creation -- same result "illegal
        operation" etc. After this there is indeed a new Win32.gid file,
        as you say. I could not find the .Fts file at all.




          This has been discussed before somewhere, I think the bug was attributed to Win98 itself and its help engine with large help files, As I recall, there was no solution

          Altough, I would also recommend getting the MSDN help files, you download the SDK setup program from the MSDN web site and choose only the help files (I also chose the header files so I could access the latest constants).


          Kev G Peel
          KGP Software
          Bridgwater, United Kingdom.
          mailto:[email protected][email protected]</A>

          [This message has been edited by K Peel (edited November 23, 2000).]


            you're right, kev.

            we discussed that topic before here. and i also can't index the win32.hlp on my win95 machine whereas on an nt4 or win2000 it's not a problem at all. it *may* have to do with memory issues. but i'm not sure on that one.

            dieny, have a look at message . certain issues about winhlp32.exe and win32api.hlp were discussed there.


            [this message has been edited by knuth konrad (edited november 24, 2000).]