Announcement

Collapse
No announcement yet.

Short Cut Underlines on button controls

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Short Cut Underlines on button controls

    Hey all,

    I'm experiencing something that seems strange. I'm creating some
    buttons on a modal dialog like this:

    Code:
    CONTROL ADD BUTTON,   hMainDlg&, %frmMain_cmdAbout,"&About",     23, 173, 45, 15, CALL cbcmdAbout
    CONTROL ADD BUTTON,   hMainDlg&, %frmMain_cmdHelp, "&Help",      70, 173, 45, 15, CALL cbcmdHelp
    CONTROL ADD BUTTON,   hMainDlg&, %frmMain_cmdBack, "< &Back",   200, 173, 45, 15, CALL cbcmdBack
    I'm using the ampersands to create shortcuts for the buttons. The
    weird thing is that the "underlines" on the buttons don't show up
    until I actually hit the ALT key, after running the software. If
    I never hit the ALT key while running the software, the underlines
    never appear. Any help would be much appreciated.

    Thanks,
    Scott

    ------------------
    Scott Wolfington




    [This message has been edited by Scott Wolfington (edited March 05, 2003).]
    Scott Wolfington
    [url="http://www.boogietools.com"]http://www.boogietools.com[/url]

  • #2
    That is a Windows 2000 feature (and possibly some other versions of Windows too). It can be enabled/disabled through Control Panel.


    ------------------
    Lance
    PowerBASIC Support
    mailto:[email protected][email protected]</A>
    Lance
    mailto:[email protected]

    Comment


    • #3
      Interesting. I am, indeed, running Windows 2000. Thanks Lance!

      Scott


      ------------------
      Scott Wolfington


      [This message has been edited by Scott Wolfington (edited March 05, 2003).]
      Scott Wolfington
      [url="http://www.boogietools.com"]http://www.boogietools.com[/url]

      Comment


      • #4
        Where in control panel is this setting?

        ------------------
        Thanks,

        Doug Gamble
        mailto:[email protected][email protected]</A>
        Thanks,

        Doug Gamble
        [email protected]

        Comment


        • #5
          I'm not near a Win2K machine to be able to tell you right now... it may possibly be under Internet Explorer's options too.

          The option is called something like "show keyboard shortcuts" or something equally obtuse.


          ------------------
          Lance
          PowerBASIC Support
          mailto:[email protected][email protected]</A>
          Lance
          mailto:[email protected]

          Comment


          • #6
            Doug -

            Right-click on the Windows 2000 desktop and select Properties. Then select the Effects tab and you'll see a checkbox marked "Hide keyboard navigation indicators until I use the Alt key".

            -- Eric


            ------------------
            Perfect Sync: Perfect Sync Development Tools
            Email: mailto:[email protected][email protected]</A>
            "Not my circus, not my monkeys."

            Comment


            • #7
              I was close! Thanks Eric.

              Note that Display Properties|Effects is available via Control Panel.

              ------------------
              Lance
              PowerBASIC Support
              mailto:[email protected][email protected]</A>
              Lance
              mailto:[email protected]

              Comment


              • #8
                Thanks Eric, that's much better! Sheesh, Microsoft!!!

                ------------------
                Tom Hanlin
                PowerBASIC Staff

                Comment


                • #9
                  Thanks Eric...some days I feel like a need a secret decoder ring
                  to work in M$ products!

                  ------------------
                  Thanks,

                  Doug Gamble
                  mailto:[email protected][email protected]</A>
                  Thanks,

                  Doug Gamble
                  dga[email protected]

                  Comment

                  Working...
                  X