Announcement

Collapse
No announcement yet.

Current PBRes.EXE & RC.EXE for PBWin-8.04 & PBCC-4.04?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Current PBRes.EXE & RC.EXE for PBWin-8.04 & PBCC-4.04?

    I'm having trouble with a Resource file that I don't believe was a problem before.

    When I upgraded to version 8.04 from 8.03 I had trouble with the install and found I needed to uninstall everything and reinstall from the original CD and step through the subsequent upgrades. While this was more tedious than it could have been, I'm now wondering if I ended up loosing a previously fixed problem with my resource compiling programs.

    Can someone look to see if these two resource programs are those that should be current to version PBWIN-8.04 & PCBB-4.04?
    Code:
    PBRes.exe   66 KB  Application   11/1/2006 8:03 AM
    RC.exe      29 KB  Application    2/1/2005 8:00 AM
    Roger...

  • #2
    Roger, my set up has rc.exe with the same time stamp as pbres.exe and the former is at version 4.0.1371.1

    Added: That was in my Win folder. In my CC folder rc.exe has a different time stamp but it is the same version and a file comparison shows the files to be identical.
    Last edited by David Roberts; 28 Oct 2007, 02:27 PM.

    Comment


    • #3
      These are from "Bin" folder of PB/Win 8.04 installation:
      Code:
      RC       EXE        28.944  01/03/05   8.01 RC.exe
      PBRES    EXE        67.584  01/11/06   8.03 PBRes.exe
      (dates are DD/MM/YY).

      Typing

      RC /?

      from that folder gives:
      Code:
      Microsoft (R) Windows 32 Resource Compiler, Version 4.00 - Build 1367
      , and typing PBRES gives
      Code:
      PBRES 1.86 - PowerBASIC Resource Converter
      Copyright (c) 1997-2004 PowerBASIC, Inc.

      Comment


      • #4
        BTW, right-clicking on RC.EXE, properties, shows "File version" 4.0.1371.1, just like David.
        For PBRes.exe it's 1.86.0.0 .

        Comment


        • #5
          Just to confuse the issue, I have at least a couple of Microsoft SDKs installed which contain RC.EXE and they override the local PB one and my PB stuff builds fine.
          hutch at movsd dot com
          The MASM Forum - SLL Modules and PB Libraries

          http://www.masm32.com/board/index.php?board=69.0

          Comment


          • #6
            I guess I have the latest versions as they match what was shown. I must have some hidden characters in the problem RC file so I'll need to test it for that issue.

            Thanks for taking the time to help.
            Roger...

            Comment

            Working...
            X