Announcement

Collapse
No announcement yet.

PB Win 8.04 help: broken link

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Frank W. Kelley
    replied
    Thanks for the response, Steve. I've already upgraded to IE7, and the version of hhctrl.ocx on my machine is 5.2.3790.2847 (a few notches later than the version you cite).

    The diagnostic tool you recommended reported no problems.

    As I mentioned, this phenomenon happens very infrequently, and I'm usually too deep into resolving the issue that caused me to refer to the help file in the first place to remember exactly what steps I took to cause the help topic to lock on me. If the time comes that I can reproduce it at will, I'll be in touch.

    Leave a comment:


  • Steve Rossell
    replied
    Originally posted by Frank W. Kelley View Post
    On a related note, calling PB Help via pressing F1 over a keyword in my code sometimes causes the help window to "lock" on the displayed topic; selecting a different keyword in the help pane on the left has no effect. Closing the help window and re-opening it usually resolves the problem. This occurs on my WinXP (SP2) machine.

    Anyone else experience this "feature"?
    Try installing the latest HTML Help security patch (http://support.microsoft.com/kb/896358), if you haven't already done so. This is typically delivered via Windows Update and, on XP, it upgrades the version of hhctrl.ocx to 5.2.3790.2453.

    If this does not help, try the steps at http://support.microsoft.com/default.aspx/?kbid=822989.

    If these do not resolve the problem, try re-registering the HTML Help ActiveX control from the command line. To do this, open a Command Prompt window and type these two commands:

    regsvr32 /u %windir%\system32\hhctrl.ocx
    regsvr32 %windir%\system32\hhctrl.ocx

    The first command unregisters the control; the second registers it again.

    Also, make sure that you do have all the Windows XP updates installed and you may consider upgrading to IE7, as IE installs the core HtmlHelp components. I really hate to say this, I know how Windows updates can be, but if the above steps to not resolve this, it maybe your only choice?

    And lastly I can suggest that you run MJ's Help Diagnostics from http://www.helpware.net/downloads/, which will check the status of all the HTML Help viewer components on your system. If need help you can send this report to [email protected]

    Leave a comment:


  • Steve Rossell
    replied
    If you have found a bug in the help file or in any product, please report it to [email protected].

    Leave a comment:


  • Frank W. Kelley
    replied
    On a related note, calling PB Help via pressing F1 over a keyword in my code sometimes causes the help window to "lock" on the displayed topic; selecting a different keyword in the help pane on the left has no effect. Closing the help window and re-opening it usually resolves the problem. This occurs on my WinXP (SP2) machine.

    Anyone else experience this "feature"?

    Leave a comment:


  • Knuth Konrad
    replied
    Could this be a subtle hint that Null Pointers are evil?

    Leave a comment:


  • Chris Holbrook
    replied
    Originally posted by Dave Biggs View Post
    I have the same..
    OK, I'll ask Mr Zale for me money back!

    Leave a comment:


  • Dave Biggs
    replied
    It's not just your files - I have the same here (PBWin 8.04).
    The Pointer variable type link (probably to the Pointers (@) topic) is broken.

    Leave a comment:


  • Chris Holbrook
    started a topic PB Win 8.04 help: broken link

    PB Win 8.04 help: broken link

    Don't know if this is just my files or what.

    In the index, topic Data Types.Data Handling, second table, first row, "Pointer" is underlined but doesn't link to anything, just produces an error message "Selection is not associated with any topics"
Working...
X