Announcement

Collapse
No announcement yet.

LPRINT ATTACH problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    From your Win 7 computer, can you ping the dispatch1 computer?
    Is it possible that during the update something got disconnected between
    the 2 computers ( maybe different IP for dispatch1 that didn't survive the
    update ) or maybe something to do with UAC rights between the 2?

    Comment


    • #22
      Yes can ping it ok.

      Did a clean install. Can print to the printer within windows from any other worstation. Also can print to it with DDOC just can use LPRINT ATTACH

      I remember that this was a problem in the compiler that was fixed but seems it's back for me.
      Last edited by Steve Bouffe; 27 Apr 2012, 04:13 AM.

      Comment


      • #23
        How about setting it as the default printer and doing LPrint Attach Default ?
        Then check out what LPrint$ shows as the printer name.

        Comment


        • #24
          FWIW
          I have found it less troublesome to create a windows printer device and set up the share in the printer device.
          Of course our workstations are few in number at each location.
          I am not sure that this will solve your problem.
          Of course the printer device name spools printout so that way it could help or hurt you depending on your situation.
          p purvis

          Comment


          • #25
            Could be something to do with Win 7 as the previous installation was XP Pro and I haven't changed anything else
            Well, changing "only" the operating system is changing a lot; so yes, your problem definitely could be something related to the new O/S and how you have set things up.
            Michael Mattias
            Tal Systems Inc.
            Racine WI USA
            mmattias@talsystems.com
            http://www.talsystems.com

            Comment


            • #26
              Originally posted by Steve Bouffe View Post
              Hi Gary,

              Tried this but still Error 68

              Code:
              LOCAL PPP as string
              
              PPP = "\\dispatch1\Epson LX-300+II ESCP"
              
              LPRINT ATTACH UCODE$(PPP)
              
              PRINT ERR
              what OS is 'dispatch1' running? During a recent upgrade/conversion at work, we found that LPRINT ATTACH commands that would work just fine on shares hosted on 32bit Windows 2003 would fail (Err 68) on 64Bit Windows 2008R2

              This is a couple months ago, I don't recall what revision of PB/Win 10 we were using. I haven't had a chance lately to test the problem further.
              Real programmers use a magnetized needle and a steady hand

              Comment


              • #27
                All systems in the network except the server are running Win7 32bit

                Comment


                • #28
                  Steve -

                  FWIW - In message #1 and #11 you referred to your printer as
                  Printer_Name_GL = "\\dispatch\EPSON LX-300+II".

                  In message #16 it is
                  PPP = "\\dispatch1\Epson LX-300+II ESCP".

                  Maybe significant, maybe not? Also I see in the 9.05 docs that
                  the printer name cannot exceed 32 characters. The last
                  referenced one was 32 exactly.

                  You might try a shorter name.

                  Skip

                  Comment


                  • #29
                    I recently got a report that one of my programs gives a message to install a printer when the printer is already installed. This is on a Win7 64 bit machine, AMD I think. The program has been used by thousands of people and this is the first complaint of its type. I'll have to look into it, but first I have to find somebody with said OS and machine. Sounds similar to what's been discussed here.

                    Comment


                    • #30
                      Originally posted by Bob Zale View Post
                      Steve, please note the explanation:

                      It must be an ANSI string with a UCODE$() override. Nothing else will work.

                      You are trying to use a wide unicode string with a UCODE$() override. Should be:

                      LOCAL Printer_Name AS STRING


                      Bob
                      Hi Bob,

                      I have the same problem, but it is not resolved bij overriding the Ansi string to Unicode. I used:

                      DIM PrinterName as STRING
                      PrinterName=\\Server\LabelPrinter-1
                      LPRINT ATTACH UCODE$(PrinterName)

                      and get a 'Device Unable' (68) Error.

                      When I redirect the printer with NET USE LPT1: \\Server\LabelPrinter-1 and change the source with:
                      PrinterName="LPT1"

                      then it works fine. But my application has to print to more than one network printer and I do'nt want to SHELL to execute then 'NET USE' command.

                      What is wrong?

                      Comment


                      • #31
                        Please note the original post. This workaround is ONLY for versions 6.00 and 10.00. It was updated in 6.01/10.01 and later versions.

                        Regards,

                        Bon Zale

                        Comment


                        • #32
                          I don't know is this applies; but make sure the printrt name and the printer share name are the same. I had a printer that was named okidata184m and the share name was okidatam. I could not get lprint to find the printer until I made them the same.

                          Comment


                          • #33
                            Hi all,

                            There is no way to make lprint attach work on Windows 7.
                            On XP compiled with PBCC4 work ok.
                            On XP compiled with PBCC6.03 not working.
                            On Windows 7 64bits compiled with PBCC4 not working.
                            On Windows 7 64bits compiled with PBCC6.03 not working.

                            Can't attach neither using UNC "\\SERVER\PRINTER", nor capturing the port by "NET USE LPT1 \\SERVER\PRINTER". Always get error 68.

                            The printer is named "PRINTER" and shared by the same name "PRINTER".

                            If i call "COPY FILE_TO_PRINT.TXT LPT1" after capturing port or
                            "COPY FILE_TO_PRINT.TXT \\SERVER\PRINTER" printing is done.

                            Bob, can you help me ?

                            Code:
                            #COMPILE EXE
                            #DIM ALL
                            
                            FUNCTION PBMAIN () AS LONG
                            
                                LOCAL IMPR AS STRING
                            
                                IMPR = "LPT1"
                                'IMPR = "\\SERVER\PRINTER"
                                LPRINT ATTACH IMPR
                                IF ERR = 0 THEN
                                    LPRINT "Testing..."
                                    LPRINT CLOSE
                                    PRINT "LPRINT Ok!"
                                ELSE
                                    PRINT "Attaching error:"; ERR
                                END IF
                            
                            END FUNCTION

                            Comment


                            • #34
                              Does it work locally on a shared printer.
                              If so.
                              For the heck of it. Try SLEEP 2500 after the ATTACH statement
                              p purvis

                              Comment


                              • #35
                                Hi Paul,

                                Locally, if the micro has an LPT port, works ok!
                                My printer is attached to an USB port remotely on server "SERVER".
                                The printer has both USB and LPT connectors. I can't physically change the printer location.
                                I need to send Zebra PCL commands to the printer... That is the reason of using LPRINT...
                                I can't change my application to send graphics by XPRINT.

                                Thanks

                                Printer model: ARGOX OS-214
                                Last edited by Gilmar de Paula Fiocca; 8 Jun 2012, 02:00 PM.

                                Comment


                                • #36
                                  When we use a shared printer device located on a different machine. We have found it better to create a printer locally then use a network port for that printer.
                                  If the printer has a network card or is on the network on its own in any way. We do the same.
                                  We use use group policy(gpedit.msc) to keep any printer devices from being deleted.
                                  In other words. We let our systems handle the remote attaching which is very useful when a computer with the printer is down.
                                  Of couse doing so will allow the spooler part to be used unless you have spooling turned off.
                                  This also allows for you to set the printer drvice to wait for the whole print job before the data is sent to the printer solving issues of any multiple users printing at the same time.
                                  FYI We do not use any windows servers.
                                  p purvis

                                  Comment


                                  • #37
                                    Code:
                                     
                                      LPRINT ATTACH.... 
                                      ...
                                      LPRINT Pcl$ + text 
                                      LPRINT Pcl$ + text 
                                     ...
                                    ===>
                                    Code:
                                       OPEN "printername" for OUTPUT as hOut
                                      Global Seach and replace "LPRINT "  with "PRINT #hout, " 
                                       resulting in: 
                                       PRINT #hOut, pcl$ + Text 
                                       PRINT #hOut, pcl$ + Text 
                                       ...
                                    ????


                                    MCM
                                    Michael Mattias
                                    Tal Systems Inc.
                                    Racine WI USA
                                    mmattias@talsystems.com
                                    http://www.talsystems.com

                                    Comment


                                    • #38
                                      Better still... MACRO it...

                                      When ATTACH is working....
                                      Code:
                                      MACRO  PRintMe (text) =  LPRINT Text
                                      If Attach still not working
                                      Code:
                                      MACRO  PRintMe (text) =  PRINT #hOut, Text
                                      ???
                                      Michael Mattias
                                      Tal Systems Inc.
                                      Racine WI USA
                                      mmattias@talsystems.com
                                      http://www.talsystems.com

                                      Comment


                                      • #39
                                        My sister prints a lot of letters to a printer with only a parallel port hookup.
                                        The printer is a specialty printer also.
                                        I moved her to an iMac because her PC computer was way too old and that iMac has no parallel ports.
                                        We bought a network printer device that hooks up to a parallel port on a printer.
                                        She runs Fusion on the Mac that allows her windows programs to print to a network device(the device we installed on the printer) and everything is cherry and the device reports back to her operating system when the printer is not ready to print for whatever reason.
                                        We then went back and bought several more in the event the one she is using breaks.
                                        The printer device in the operating system is set to use a ip address as a printer port.

                                        the device has startech.com written on it
                                        http://www.startech.com/Networking-IO/Print/1-Port-Parallel-10100-Mbps-Print-Server~PM1115P
                                        http://www.provantage.com/startech-pm1115p~7STRN01Y.htm

                                        We have used another device for usb only printers. linksys psus4
                                        The linksys psus4 runs a built-in linux operating system.
                                        We used the linksys psus4 on laser printers that had no network port but an usb port.
                                        The problem i had with those devices is that i had to reboot each one about 3 times a year when the printing part of the device would quit sending data to the printer.
                                        The hub part still worked on the linksys psus4 even though the printing part of the device failed.
                                        I figured it was due to bad electricity because they where only connected to the a power strip for power and no battery backup.
                                        But my people would forget to recycle the power on the linksys psus4 when it had printer issues. Now all laser printers have a cable ethernet port on them and no issues.


                                        And i leave you with this. Back in the msdos days, if i remember correctly, the LPT ports had a high priority in the msdos os system and the floppy drives have a higher priority.
                                        I really do not know how the windows multitasking os system comes into play with with LPT ports and floppy drives, but i just never liked printers attached to my servers.
                                        Because i did not want my servers using too much cpu time communicating with a printer.
                                        But this is only my thoughts on printers.

                                        I can tell you for a fact that i have had a lot of problems with trying to use usb drives as a shared device through the windows 2000 and xp os systems. Basically do not do that is my hard learned lesson.
                                        I get major disk cache writing problems even when i have turned off write behind cache and the computers will still freeze.
                                        I do have single processors on most all our equipment and a dual processor many be better and has shown me to be better. A dual processor works much better and more stable on any kind of server than a single processor.
                                        That does not matter what kind of operating system you have either.
                                        Last edited by Paul Purvis; 8 Jun 2012, 05:08 PM.
                                        p purvis

                                        Comment

                                        Working...
                                        X