Announcement

Collapse
No announcement yet.

Dialog Pixels Bug?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dialog Pixels Bug?

    Don’t think it’s me, but would appreciate if someone else could verify if the ‘DIALOG PIXELS’ command has a minor bug, I am running PB10 version 10.04.0108.

    I had a dialog client area which measures x=795 pixels (530 dialog units), y=487 pixels (300 dialog units), I wanted to convert to dialog units so used the DIALOG PIXELS command
    DIALOG PIXELS hWindow, pixlesX, pixlesY TO UNITS unitsX, unitsY

    The resulting unitsX = 300 & unitsY = 530, result is correct but wrong way around from the help documentation.

    Thanks
    Richard

  • #2
    Yes, it's a reported bug in v10.04, but not in 10.03 or earlier. Same with UNITS to PIXELS. Quick fix:
    Code:
        IF %PB_REVISION = &H1004 THEN SWAP unitsX, unitsY

    Comment


    • #3
      Or...
      Code:
      #IF %PB_REVISION = &H1004
       SWAP unitsX, unitsY
      #ENDIF
      "Not my circus, not my monkeys."

      Comment


      • #4
        Thanks guys, appreciated.
        Richard

        Comment


        • #5
          Thanks a lot for this post. I was getting graxy
          thinBasic programming language
          Win10 64bit - 8GB Ram - i7 M620 2.67GHz - NVIDIA Quadro FX1800M 1GB

          Comment


          • #6
            Graxy? That's a new one too me. (and apparently to Google too)

            Comment


            • #7
              Sorry *crazy
              thinBasic programming language
              Win10 64bit - 8GB Ram - i7 M620 2.67GHz - NVIDIA Quadro FX1800M 1GB

              Comment


              • #8
                I thought it might be that, but wasn't sure

                Comment

                Working...
                X