Announcement

Collapse
No announcement yet.

Slow compiler

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slow compiler

    I have been using PB for quite a few years without problems but my compiler has started to get slower and slower.
    Compiling code of just a few lines is taking about six seconds which, for PowerBasic 10 is ridiculously slow.
    I think it may be something that has got into my system.
    Has anyone experienced this sort of thing happening?
    Brian.

  • #2
    Antivirus is the prime suspect.
    Forum: http://www.jose.it-berater.org/smfforum/index.php

    Comment


    • #3
      It seems to me that someone once posted that the editor output box at the bottom of the IDE can cause this if you don't empty it.
      Rod
      I want not 'not', not Knot, not Knott, not Nott, not knot, not naught, not nought, but aught.

      Comment


      • #4
        What Rod said is correct, just right click at the bottom box where there is a title "Welcome to PB/Win IDE 10"
        and then click on Clear All to empty it.
        Maybe do an anti virus scan in safe mode to see if there is any malware infestation?

        Comment


        • #5
          Thank you, gentlemen. I'm having some difficulty finding where to clear the Editor Box. I can't see "Welcome to PB/Win IDE 10". I think it doesn't like me.
          However, I'll keep trying.
          Brian.

          Comment


          • #6
            Brian,
            Move your mouse around the bottom of the IDE until you see an Up/Down sizing bar. Click and hold the mouse and drag up the top of the editor output box.
            Closing and reopening the IDE will also clear the editor output box.

            Comment


            • #7
              That phrase scrolls out of view as you do compiles. It is the box where compile errors appear, or "Successfully created …" appears.
              Dale

              Comment


              • #8
                For me, the use of the improved #RESOURCE meta statements in PBwin10 means 5-6 seconds longer compile time. Therefore I still prefer using "the old way" via .RC compiled to .PBR, etc.

                Comment


                • #9
                  Unless Brian is using a very old machine, the internal resource statements work fine and usually fast enough. I would go with Jose's suggestion, check for any viral or trojan infections, if that is clean, make an exception in the AV software so it does not scan the compiler / output exe.
                  hutch at movsd dot com
                  The MASM Forum

                  www.masm32.com

                  Comment


                  • #10
                    Windows Defender AntiMalware plays havoc on compiled apps.

                    Comment


                    • #11
                      I lost a few programmes including PowerBasic and EZGUI which I use a lot. I have re-installed both these programmes and the same problem occurred.
                      I copied my PB code to a text file, then loaded it into the PB IDE and saved it under a new name. It copiles as quickly as it used to.
                      Obviously I have an anti-virus which is causing trouble. I just have to find it. I thought I had removed all anti-virus from my computer.
                      Thank you to all who have offered a solution to my problem.
                      Brian.

                      Comment


                      • #12
                        then loaded it into the PB IDE and saved it under a new name.
                        That is the key to avoid problems with Windows Defender Antimalware. If I may ask, what names were you using and what did you change them into?

                        Comment

                        Working...
                        X