Announcement

Collapse
No announcement yet.

Jose's library compatibility with PB9 and/or PB8 compling vs PB10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jose's library compatibility with PB9 and/or PB8 compling vs PB10

    Was #INCLUDE THIS ONCE purely a PB10 add on feature. When using C:\PBWIN10\WINAPI_III_104 (Jose's windows api) #INCLUDE THIS ONCE works fine in PB10, but does not compile in PB9 or PB8. When I removed #INCLUDE THIS ONCE (thinking it wasn't needed) I started getting other errors trying to compile the same program in PB9 or PB8. I imagine there must be earlier versions of WINAPI_III_??? that I can use to compile with.

    Bob Mechler

  • #2
    Yes. #INCLUDE THIS ONCE new in PBWin 10 and PBCC 6.

    #INCLUDE ONCE new in PBWin 9 and PBCC 5.

    Dale

    Comment


    • #3
      The headers for PB10 won't work with PB9. There are headers for PB9 here:
      Windows API Headers for PB 9 & CC 5 - PowerBASIC Peer Support Community

      But be aware that with that outdated compiler you won't be able to compile most of code posted in this forum.
      Forum: http://www.jose.it-berater.org/smfforum/index.php

      Comment


      • #4
        Thanks, we standardized on PB 9 for new programs years and years ago and our other programmers only have PB9. Appreciated.

        Comment

        Working...
        X