No announcement yet.

Error 57 using TCP

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 57 using TCP

    I've tried about every example there
    is including Don Dickinson's Rserver
    and RsTest. Keep getting error 57
    from the client. I'm able to get
    pages etc using the browser to my
    server so I know the connection is
    working. I've turned off firewalls
    and tried even using port 7 (no luck.)
    The server is sitting there waiting
    on port 7 and my port monitor shows
    it listening. Anyone have a suggestion?
    Both programs are definitely set to port 7.


  • #2
    Is it a 98box and are you trying to open an ip address instead of a domain name? ... if so, this is a previously reported issue. To get around it, create a file (or edit an existing one) called "HOSTS" in the windows directory. In this file put (or append) a line like this ...

    change to be the IP address you're trying to open and is a fake domain name for that IP address. Now in your open statement, put "" in place of the IP address. I bet it works.


    Don Dickinson


    • #3
      I'll give it a try in a bit and post the results. Thanks.



      • #4
        for most cases, the solution appears to be to install the ms network client... see

        powerbasic support
        mailto:[email protected][email protected]</a>
        mailto:[email protected]