Announcement

Collapse
No announcement yet.

WAV File Not Playing on Headset

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • WAV File Not Playing on Headset

    I used Play Wave in my PowerBASIC app with the file phaser.wav and it played on my PC speakers just fine.

    http://www.garybeene.com/files/phaser.wav

    Code:
    #Resource Wave, xalarm, "alarm.wav"
    #Resource Wave, xphaser, "phaser.wav"
    But then, I switched to my Bose QC 35 II headset (noise cancelling) and I could not hear the .wav file when the app tried to play it.

    I tried a different file (alarm.wav) and I could hear it on my PC and on my QC35.

    I tried a different app (non-PBWin) and could hear the phaser.wav file on my QC35.

    That's an odd set of results. Anyone seen something similar to this?

  • #2
    Hi Gary

    Originally posted by Gary Beene View Post
    I used Play Wave in my PowerBASIC app with the file phaser.wav and it played on my PC speakers just fine.

    http://www.garybeene.com/files/phaser.wav

    That's an odd set of results. Anyone seen something similar to this?
    Can you hear the sound when using something else, e.g. the browser to play it? If not, it seems that the head set's noise canceling supresses the sound, as it "thinks" phaser.wav simply is noise.

    Albert
    „Let the machine do the dirty work.“
    The Elements of Programming Style, Brian W. Kernighan, P. J. Plauger 1978

    Comment


    • #3
      What result do you get using PLAY WAVE with the phaser.wav file (instead of the resource)?
      Rgds, Dave

      Comment


      • #4
        Howdy, Albert!
        Yes, I can double click on the file and it plays just fine.

        Howdy, Dave!
        With this ...

        Code:
        Play Wave "phaser.wav"
        ... I do NOT hear the file on my headset.

        Comment


        • #5
          Hmm,

          How about with this test code?..
          '
          Code:
          #DIM All
          #COMPILE EXE
          #INCLUDE "WIN32API.INC"
           
          FUNCTION PBMAIN()
           
            Play Wave "Phaser.wav" Loop
            Sleep 500
            Play Wave End
          
           '  SndPlaySound "Phaser.wav", %SND_ASYNC 'Or %SND_Loop
              
            MSGBOX "Done",%MB_SYSTEMMODAL,Error$
           
          END FUNCTION
          '------------------/PBMain
          500ms should play 3-4 times
          SndPlaySound uses a subset of the PlaySound API functionality that PLAY WAVE is based upon.
          Rgds, Dave

          Comment


          • #6
            Howdy, Dave!

            With your code and without the headphones I heard the phaser sound about 4 times.

            With headphones, I heard it one time.

            Comment


            • #7
              Originally posted by Gary Beene View Post
              Howdy, Dave!

              With your code and without the headphones I heard the phaser sound about 4 times.

              With headphones, I heard it one time.
              Looks like you need different headphones

              Comment


              • #8
                Something of a timing problem?
                How about with SndPlaySound - do you need to loop to hear with the headphones?
                Rgds, Dave

                Comment


                • #9
                  Lots of stuff on the intertubes about problems with Bose QC 35 and WIndows 10. It seems to be tied up with the fact that there are both "Hands Free" and "Stereo" modes. Also they apparently can do automatic cancellation of system notifications sounds.

                  You may like to try this:
                  1) If you had already connected and paired your Bose QuietComfort 35 to your computer, please uninstall it then restart your computer.

                  To do this, swipe from the right hand side of your screen and tap on "All Settings".

                  Tap on "Devices", then "Bluetooth".

                  Tap on the Bose Icon and "Remove Device". It will un-pair and uninstall your headphones.

                  Restart your computer.

                  2) When your computer re-starts, make sure that your computer Bluetooth is enabled. Then swipe again from the right and tap on "All Settings"...."Devices"..."Bluetooth".

                  Turn on your Bose Headset and move the power switch ALL THE WAY to the right and hold it there for a several seconds.

                  Two (2) Bose icons are going to appear. Click on the icon with the headphone! The headphone icon may not appear immediately, but wait for it. Pair it.

                  3) On the bottom right hand side of your screen, you will see the icon for the speaker. Right-click on it. Select "Playback Devices".

                  You will see two Bose icons, "Headset - hands free" and Headphones - stereo".

                  Right-click on the "Headset, hands free".

                  Tap on "Disable"

                  4) Restart your computer.

                  I hope this helps.




                  There are also a number of discussions about updating the headphones "firmware".

                  Added; Something else to consider. DO you have then connected to two device? Is it taking too long to switch?

                  The headphones doesn’t automatically switch to the device playing content
                  The Bose QuietComfort 35 II can connect to two devices simultaneously, and will automatically switch to the device playing content. While convenient, the headphones may sometimes switch to the wrong device—even when it’s not playing anything. You can override automatic switching by selecting your device using the Bluetooth toggle switch, located on the right ear cup.

                  Comment


                  • #10
                    Originally posted by Gary Beene View Post
                    Howdy, Dave!

                    With your code and without the headphones I heard the phaser sound about 4 times.

                    With headphones, I heard it one time.
                    Another thought - Have you tried setting the HeadPhones to 'Default Device' in mmsys.cpl,,playback ?
                    Rgds, Dave

                    Comment

                    Working...
                    X