Announcement

Collapse
No announcement yet.

Curious Lynx / Jellyfish truncated path...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Curious Lynx / Jellyfish truncated path...

    I've been using Jellyfish Editor with Lynx project explorer and found something kinda curious....

    In doing a very simple task of retrieving the current path, I kept getting a truncated path name such "c:\blah\blahbl~1" when compiling / testing my code. I tried GetCurrentDirectoryA also, same thing....

    This happens when Using F5 (compile / Run) when Lynx is running with Jellyfish.

    IF:

    a) Lynx is terminated, full path returned
    b) PBedit is used instead of Jellyfish, (not F5 now), full path returned
    c) using Jellyfish / Lynx I get the full path correctly if I select "compile project" or "compile and run" from Lynx menu, no problem either (disabled in Jellyfish)...
    d) running the compiled exe, worked correctly also...

    Guess, I got too used to hitting F5...

    It's a simple test...make sure the current directory is a long name then run:

    LOCAL st_testdir AS STRING

    st_testdir = CURDIR$

    MSGBOX (st_testdir)

    Not a big deal, but might leave you scratching your head sometime....
    "Show me a young Conservative and I'll show you someone with no heart. Show me an old Liberal and I'll show you someone with no brains." ― Winston Churchill
    "Socialism is the philosophy of failure, the creed of ignorance and the gospel of envy." ― Winston Churchill

  • #2
    Similar Issue Maybe

    After installing Lynx, JellyFish Editor and PB on one of my customers machines so I can develop remotely using an RDP session with Citrix, I came across the following issue:

    Lynx cannot pass the filename to the compiler correctly as it only passes the path up to the last backslash "\". THe compiler then times out with an error message.

    I have to close Lynx and use the compile button from JellyFish which works fine.

    I have been in contact with Paul Squires with lots of help and unfortunately no resolution and for now I am blaming it on Citrix. We tried reinstalling and setting up without editing the Project.LNX file using notepad (My Bad - I can't help it!)

    It works on the dozen or so other machines where I have installed this configuration and use RDP daily (with no Citrix).

    Peter

    Comment


    • #3
      Originally posted by Peter House View Post
      I have been in contact with Paul Squires with lots of help and unfortunately no resolution and for now I am blaming it on Citrix.
      You must mean Paul Noble, right? I can't remember dealing with this issue.
      Paul Squires
      FireFly Visual Designer (for PowerBASIC Windows 10+)
      Version 3 now available.
      http://www.planetsquires.com

      Comment


      • #4
        True Dat on Paul Noble

        Looking back at my correspondence, it was indeed Paul Noble. Either there are too many Pauls or too few brain cells

        Peter House

        Comment


        • #5
          Slightly Off Topic

          By the Way. Both the Jellyfish Pro Editor and the Lynx Project Editor are awesome products separately - Used together they are simply indescribably awesome.

          Thanks to BOTH Pauls !!!

          Comment


          • #6
            GetLongPathName()
            GetShortPathName()

            .. can be used to convert between 8.3 and 'long' filenames....

            MCM
            Michael Mattias
            Tal Systems (retired)
            Port Washington WI USA
            [email protected]
            http://www.talsystems.com

            Comment

            Working...
            X