Announcement

Collapse
No announcement yet.

JK-IDE Version 2.0 including Visual Designer V 1.0

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Hi all,


    V 2.2.0.3 is online - fixed a rare focus (timing) issue when switching from PowerBASIC to FreeBASIC and vice versa


    JK

    Comment


    • #62
      Hi all,


      V 2.3.0.0 is online - this a major update! i added Unicode support for the editor, that is you may enter literal Unicode strings now, the corresponding file must be in Unicode mode, please read more in the help Editor\Unicode. As a consequence an existing ToDo list and text in the macro definition window may appear strange and must be re-written, this applies to characters above ASCII 127. Intellisense is faster now, no auto intellisense for small language keywords (<6 characters), but you can still force it (Ctrl + Space). You may select multiple files now in the recent files listbox for re-opening now.

      As always i did my best trying to avoid new bugs with new features. This update required many additions and changes in many different locations. Some more changes will be necessary to make literal Unicode strings possible in the VD, which doesn´t support literal Unicode string currently. This is a feature yet to come. Please report problems and bugs as you find them


      JK

      Comment


      • #63
        Uh Oh Juergen,

        I'm running version 2.3.0.0
        While having the Find dialog up and text highlighted in the document pressing Control Shift F does not update the Find dialog Find What dropdown textbox it just shifts the focus to the Find dialog. Likewise the Find and Replace dropdown textbox is not updated with highlighted document text when pressing Control Shift R.

        Comment


        • #64
          Hi Jim,


          V 2.3.0.1 is online fixing this and some other minor issues with the last update - thanks for reporting


          JK

          Comment


          • #65
            When activating the search dialog, it would be nice if the higlighted text was entered into the searcg dialog.
            Now I highlight my search text - do a control C , F, V.
            Trento Castricone
            www.fileraptor.com
            trento@castricone.com

            Comment


            • #66
              Hi Trento,


              you must do a Control + Shift + F to get the current word (or highlighted text) into the Find Dialog, Control + F opens the Find Dialog and sets the last search term of this session, if any.


              JK

              Comment


              • #67
                Hi all,


                V 2.3.0.2 is online, a major update for the the Visual Designer (V 1.5.0.0) it now supports literal Unicode strings as well. That is you now may directly create controls with Russian, Greek or Chinese text and tooltips.

                As always i did my best trying to avoid new bugs with new features. This update required many additions and changes in many different locations. Please report problems and bugs as you find them


                JK

                Comment


                • #68
                  Hi all,


                  V 2.3.0.3 is online, the Visual Designer (V 1.5.0.1) basically works with FreeBASIC now. You may download the necessary FreeBASIC tool chain from inside the IDE and install it for use with the IDE as an automated process. A few minor changes and fixes.


                  JK

                  Comment


                  • #69
                    JK-IDE is currently the best IDE for PB. And possibly also for Freebasic.

                    --Theo Gottwald
                    ------------------------------------------------
                    76706 Dettenheim * Germany * info@it-berater.org
                    ------------------------------------------------
                    Joses Forum * Theo's Link Site * IT-Berater.org

                    Comment


                    • #70
                      Hi Juergen,

                      I get the following error message when starting the IDE. It appears twice before the IDE opens. The IDE appears to function normally when open although I haven't tested extensively.

                      Click image for larger version

Name:	Error1.png
Views:	1
Size:	6.9 KB
ID:	773114

                      Windows 8.1 Pro with Media Center, 64-bit

                      Dennis

                      Comment


                      • #71
                        Originally posted by Dennis Hoskins View Post
                        Hi Juergen,

                        I get the following error message when starting the IDE. It appears twice before the IDE opens. The IDE appears to function normally when open although I haven't tested extensively.

                        Click image for larger version

Name:	Error1.png
Views:	1
Size:	6.9 KB
ID:	773114

                        Windows 8.1 Pro with Media Center, 64-bit

                        Dennis
                        Same here. Win 7.

                        Comment


                        • #72
                          Sorry for the invenience, the IDE is working properly, if you click "OK" in the two error boxes!

                          As far as i can tell by now, it seems to be related to some path settings for FreeBASIC. That is, if there isn´t the setting the IDE expects, a keyword array is dimmed with incorrect values at startup. This is annoying but does no harm. I´m working on a solution - maybe more later today


                          JK

                          Comment


                          • #73
                            Hi all,


                            V 2.3.0.4 is online - this (hopefully) fixes a bug in the previous version, (unnecessary error boxes) at startup and when switching to FreeBASIC under certain circumstances. Trying to beautify my tested and working code, i made a typo, which compiled but mixed up my logic...


                            JK




                            Comment


                            • #74
                              Hmm,
                              Not quite there yet. Several other messages popped up. One was a CHECKFOR error and one was a bad file name error plus the final update dialog says, "You are running the latest version#: 1.5.0.0."

                              Comment


                              • #75
                                Hi Jim,


                                i can confirm the wrong version number (internally it actually is V 2.3.0.4), but i cannot replicate all the other things you describe. Does this happen every time you start the IDE, or did it happen only the first time it re-opened after the update?

                                All i can say is, it must be a result of recent changes for the FreeBASIC part. These changes affect some administrative features, but not the core functionality. I have been working with these changes for about two weeks before i made them public with version 2.3.0.3.

                                Screenshots and/or the exact text and order of the error boxes would help a lot to find out what´s going wrong. So if someone else has the same problem, please make screenshots and send them to me <jk-ide at t minus online dot de>


                                JK

                                Comment


                                • #76
                                  Hey Juergen,
                                  It was only during the update process that I noticed them. There were the original messages that were documented above and the 2 I made reference to as well. Sorry I just clicked through them.

                                  Comment


                                  • #77
                                    Jim,


                                    in the meantime i was able to reproduce what you reported with an old copy on my laptop. At least i now have something i can work with and i can confirm, that this is one time problem when updating. Afterwards the IDE works as expected again.


                                    JK

                                    Comment


                                    • #78
                                      Hi all,


                                      V 2.3.0.5 is online, hopefully fixing the problems reported by Jim and others.

                                      This was a really nasty bug, because it required several conditions to be met simultaneously for it to occur. The IDE starts several worker threads at startup doing some administrative tasks. Each thread does some file I/O and i use a variable and the "FREEFILE" statement to get unique file numbers. Copying and adapting code for FreeBASIC, which already has run for PowerBASIC for quite some time without problems, one single "FREEFILE" line somehow got lost! The code still compiles and runs - but in one file I/O place of the added code the variable for the file number isn´t updated properly. So if by chance at the same time some other thread uses the same file number an error occurs, which then leads to other errors, and so on ...

                                      You can run such code many times and get away with it without any error (this is what happend, when i tested it). But sometimes it will fail and produce the error boxes reported above. Fortunately the affected code is not "mission critical", so after clicking away the error boxes or after a restart the IDE ran as usual.


                                      Please test and report errors. If an error box pops up make a screenshot or do a Ctrl+C (which copies the content of the message box to the clipboard). I need the text of the error boxes in the correct order to be able to investigate what´s going wrong.


                                      Thanks


                                      JK

                                      Comment


                                      • #79
                                        V 2.3.0.5
                                        Looks good

                                        Comment


                                        • #80
                                          Hi all,


                                          V 2.3.0.6 is online, minor editor fixes, FreeBASIC support is ready now except for a debugger (comming next) and a browser control (maybe later)


                                          JK

                                          Comment

                                          Working...
                                          X