Announcement

Collapse
No announcement yet.

JK-IDE Version 2.0 including Visual Designer V 1.0

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hi Juergen

    Yes, something like themes, but on a single button, such as "dark theme off, on"

    Very thanks,

    Arthur.

    @Jim - put your AV to not scan the chess folder that is inside the samples folder
    "The trouble with quotes on the Internet is that you can never know if they are genuine." - Abraham Lincoln.

    Comment


    • Juergen,
      I scanned my whole drive and did not find "Chess.exe". Apparently I skipped it before. I'll likely do what Arthur suggested. Thanks

      Comment


      • Hi Arthur,


        i´m going to add what you want, if you will assist a bit. Please drop me a mail at jk-ide at t minus online dot de.


        JK

        Comment


        • Hi all,


          V 2.4.0.2 is online, the debugger for FreeBASIC is fully functional now, please read the help file ("Debugging") for further information,

          added a new feature: color themes and a dark mode switch for toggling between the current theme and dark mode, please read about themes in the help file, there might be some minor drawing problems with dark mode, but basically it works


          JK

          Comment


          • Hi all,


            V 2.4.0.3 is online, fixed some problems with the code formatter for PowerBASIC, made it work with FreeBASIC as well


            JK

            Comment


            • Hi all,


              V 2.4.5.0 is online, added support for GIT version control system and fixed some minor problems, please read about GIT in the help file


              JK

              Comment


              • Hi all,


                V 2.4.5.1 is online, improved support for GIT version control system and fixed some bugs in FreeBASIC (private/public procedures weren´t parsed properly), please read about GIT in the help file.


                JK

                Comment


                • Juergen,
                  New bug report. Recently I noticed my include tabs were disappearing from the IDE tab bar. This is an image of why this is happening.
                  Click image for larger version  Name:	Problem.jpg Views:	1 Size:	1.9 KB ID:	777877Note: the up/down control is highlighted but the TAB below it is also showing focus and when you click the up/down the result function is the close of the include. For me it is not really a big issue since I only have a few includes but I imagine that could be a real problem for those that have hundreds of includes.

                  Comment


                  • Hi Jim,


                    thanks for reporting, i never noticed it myself. But now explicitly testing it, if the close button is (partially) covered by the up/down control, it is activated, while it shouldn´t be, and clicks go through, which shouldn´t be the case either. I´m going to fix it.


                    JK

                    Comment


                    • Also I noticed that in some cases when your mouse is momentarily positioned next to the up/down control but not on the TAB close button and neither control shows focus if you click there the TAB first gains focus then the TAB close button turns red and the TAB is closed. This is a bit harder to replicate.

                      You are welcome. Always glad to help.

                      Comment


                      • Hi Jim,


                        V 2.4.5.2 - is online fixing a bug, where a mouse click in the up/down control of the file tabs could inadvertedly close a file, if the close button and up/down control overlapped. Please re-check, if it´s gone now


                        JK

                        Comment


                        • Alright. Looks good. Thanks

                          Comment


                          • Hi all,

                            V 2.4.5.3 is online, there was an unnecessary error message starting PB-Forms or the Visual Designer, when there were no open files in the IDE

                            JK

                            Comment


                            • Hi all,


                              V 2.4.5.4 is online, fixed minor visual and help issues, adaptions and additions in the help file


                              JK

                              Comment


                              • Juergen,
                                Since March 5 I have been noticing some peculiar behavior. Periodically upon opening the IDE I get this...
                                Click image for larger version  Name:	JK-IDE_BugReport01.jpg Views:	0 Size:	253.0 KB ID:	780111

                                Pressing the Dark theme twice does cause it to return to the normal screen.

                                Additionally, the Find and Replace dialogs flash multiple times when the search is ended with NO or CANCEL on the Find Next/Replace dialog. It appears to be a radical change in the focus between the main IDE and its siblings which varies from 3 to 10 times after the Find Next/Replace dialog is closed. Very noticeable when CPU resources are 80% or so.

                                Thanks

                                Comment


                                • Hi Jim,

                                  your system is Windows 10 i suppose, the IDE doesn´t start maximized and dark theme should be active - right? Did you intentionally wipe out the text of the rightmost tab and parts of the caption, or is this the real screenshot? Does it happen only when the CPU load is heavy?

                                  Clicking NO or CANCEL doesn´t close the Find or Replace dialog, so do you mean the message box? Closing the message box sets the focus back to the edit window while the Find or Replace dialog remains visible. Does the flashing occur then or if you actually close the dialog with <ESC> or the close button?


                                  JK

                                  Comment


                                  • Juergen,
                                    Yes, Windows 10.
                                    No, IDE does not usually start maximized. I typically use it at a reduced size.
                                    No, Dark theme is not implemented; but, to remove the shadow I clicked Dark theme twice.
                                    Yes, Wiped confidential areas on screen shot.
                                    No, for my system the flash behavior is evident at all times after closing the Message Box. When the CPU load is heavy the flashing is slow and very visible.
                                    Correct. I was referring to clicking on the FIND NEXT/REPLACE Message Box NO or CANCEL.
                                    Yes, the flash behavior is the same for <ESC> and dialog close button.

                                    After the FIND NEXT/REPLACE dialog is closed it appears the focus is given back to the IDE and then retracted many times. Eventually the FIND/REPLACE dialog ends up with the focus.

                                    Comment


                                    • Jim,

                                      i cannot imagine that this was introduced by the last update, but we can test it. In your IDE folder there is always the latest but one version as "jk-ide.exe.old". Just rename jk-ide.exe to jk-ide.exe.new and then rename jk-ide.exe.old back to jk-ide.exe. Then use this version (the last update didin´t contain any important or decisive changes) and tell me, if the reported behavior is still the same.

                                      I have no other reports regarding this so far, so the problem might be specific to you or your computer somehow. Let´s discuss this further via e-mail. Maybe i must provide a special debug version for you.


                                      JK

                                      Comment


                                      • Juergen,
                                        You are correct, I brought up version 2.4.5.3 and noticed the same behavior. Note: I never noticed this until I installed Java 8 which was January. See this.

                                        Comment


                                        • Recently my son had some serious problems with his Windows 10 gaming computer. After installing a new fancy video driver strange things happened every now and then. Sometimes there was no problem at all, sometimes his system froze or rebooted every 5 minutes or so. Removing the driver made it even worse, because his machine now began to crawl. Fortunately system restore was still functional and after hours of crawling finally restored the system to the state before installing this nasty software.

                                          Comment

                                          Working...
                                          X